BwPostman 4

Good things come to those who wait: Joomla! 4 is released. Not jet quite on the dot of starting Joomla! 4 there now is a new version of BwPostman, BwPostman 4.

BwPostman 4 is a complete new BwPostman, which doesn't work with Joomla! 3. Otherwise version 3.1.7 and former versions of BwPostman 3 doesn't work with Joomla! 4.

Upgrade Process

Prerequisites

  • Joomla! 3.10.x
  • BwPostman 3.1.7

Before the upgrade from Joomla! 3 to Joomla!4 You should ensure BwPostman 3.1.7 is installed. If You don't have updated BwPostman to this version: Catch up on! The upgrade to Joomla! 4 is only tested and sure with version 3.1.7 of BwPostman!

Upgrade Joomla! 3 to Joomla! 4

First You upgrade Joomla! to version 4, then You upgrade BwPostman to version 4!

As usual the upgrade to Joomla! 4 is done by Components ⇒ Joomla! Update. While upgrading Joomla! 3.10 to Joomla! 4 first a check is done by Joomla!, whether the system requirements are met and all extensions are compatible to Joomla! 4.

Pre-Update Check

At the first tab "Pre-Update Check" for BwPostman 3 is displayed, that no update information is available. This is correct, because technically considered  BwPostman 3 is another extension than BwPostman 4.

Extremely important!

If there are displayed other extensions also, then don't ignore these messages, but clarify, what You have to do to make them compatible to Joomla! 4.

Live-Update

At the second tab "Live-Update" there are named the two Plugins of BwPostman

  • Boldt Webservice LibRegister
  • BwPostman Plugin Media Override

which probably make problems at upgrade. I have processed the upgrade dozens of times without any problems. Cautious people may deactivate these two plugins, before the upgrade to Joomla! 4.

Again extremely important!

If there are displayed other extensions also, then don't ignore these messages, but clarify, what You have to do to make them compatible to Joomla! 4.

Now all is prepared on the part of BwPostman to do the upgrade to Joomla! 4. After the upgrade to Joomla! 4 You should update BwPostman immediately. If You go to System ⇒ Update ⇒ Extensions, the update to BwPostman 4 is presented.

After this update You should activate the plugin Boldt Webservice LibRegister, to ensure proper work of BwPostman 4, if You have disabled it beforehand. The plugin BwPostman Plugin Media Override is not needed for Joomla! 4 and therefore the plugin no longer exists.

 Known Bugs And Problems

Solely for the plugin User2Subscriber a bug is known: At sending of the registration the entered values are checked. Most of all whether all needed values are entered. If all values are entered except the mailing list, the registration process is not abandoned, but the user gets registered with an account for the website, a subscription for a newsletter is not created. Work in progress…

It is remarkable, that  Joomla changed the handling of permissions. So it is impossible for me leastwise,  to deliver an user group, which is able to only manage the options of BwPostman but not the options of other extensions.

 

Plugin BwPostman TimeControl

The plugin BwPostman TimeControl is not adjusted completely for Joomla!4. But a version will follow soon, which is compatible to Joomla! 4.

Final Note

Like Joomla! 4 BwPostman 4 got intensive testing before publishing. But it will probably happen, that the daily use, an endurance test,  will show bugs, which can't be detected before. Even for such a "small extension" like BwPostman, small compared with Joomla!, I can't exclude that. Because of this please expect some updates not only by Joomla! but also by BwPostman, especially because changes to Joomla! also may have an impact to BwPostman.