TOPIC:

Button Neuer Newslettern erstellen fehlt 22 Jun 2020 12:25 #1818

  • sklemme
  • sklemme's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 0
Hallo,
ich habe folgendes Problem seit kurzem, dass sich ein registrierte Person (Berechtigung Autor) keinen Newsletter NEU ERSTELLEN kann.

Wenn ich den Benztzer als SuperNutzer einstelle, hat der Nutzer im Backend den Button.

Ich habe der Berechtigung Autor zum Testen alle Rechte gegeben (alles auf grün), aber dennoch geht es nicht.

Woran kann es liegen das es der supernutzer sein muss? Es soll im backend ein Newsletter erstellt werden und versendet werden. Letzteres geht auch wenn ich ein noch nicht abgesendeten Newsletter bearbeite, dass geht nämlich als Autor.

Gruß Sebastian

Please Log in or Create an account to join the conversation.

Button Neuer Newslettern erstellen fehlt 22 Jun 2020 14:11 #1819

  • Romana
  • Romana's Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 757
  • Karma: 6
  • Thank you received: 50
Hallo Sebastian,

die Rechte von Joomla interessieren BwPostman nur am Rande, weil da manches nicht möglich ist, wie ich es haben will. Daher hat BwPostman auch eine eigene Rechte-Verwaltung.

Wenn Du diesen Benutzer in die Gruppe BwPostmanNewsletterEditor aufnimmst, müsstest Du alles haben, was Du brauchst.

Hth
Romana
Problem gelöst? Dann bitte auf gelöst klicken. Über ein Danke freue ich mich immer.
Problem solved? Please click to solved.I am glad to every thank you.

Please Log in or Create an account to join the conversation.

Button Neuer Newslettern erstellen fehlt 23 Jun 2020 08:28 #1820

  • sklemme
  • sklemme's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 0
Sollte dieses Zugriffsrecht unter der Joomla Konfiguration zu sehen sein? Bei mir ist es nicht so :-(

Wie kann ich es nachinstallieren?
Attachments:

Please Log in or Create an account to join the conversation.

Button Neuer Newslettern erstellen fehlt 23 Jun 2020 17:33 #1822

  • Romana
  • Romana's Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 757
  • Karma: 6
  • Thank you received: 50
Hallo Sebastian,

das ist kein Zugriffsrecht, das ist eine für BwPostman vorkonfigurierte Benutzergruppe. Sie müsste also bei den Benutzergruppen von Joomla zu sehen sein, neben den anderen vorkonfigurierten Benutzergruppen, die BwPostman mitbringt.

Diese vorkonfigurierten Benutzergruppen werden automatisch bei der Installation von BwPostman angelegt. Ich kann jetzt nicht sagen, ob sie auch bei einem Update oder einer Über-Installation noch mal angelegt werden. Falls nicht, kannst Du ja in der Wartung von BwPostman die Tabellen sichern, BwPostman deinstallieren, neu installieren und die Tabellen in der Wartung von BwPostman wieder einspielen. Spätestens jetzt müsstest Du die vorkonfigurierten Benutzergruppen haben.

Wie diese Benutzergruppen vorkonfiguriert sind, was welche Gruppe darf oder nicht, kannst Du in den Optionen von BwPostman auf dem Reiter Berechtigungen sehen.

Hth
Romana
Problem gelöst? Dann bitte auf gelöst klicken. Über ein Danke freue ich mich immer.
Problem solved? Please click to solved.I am glad to every thank you.

Please Log in or Create an account to join the conversation.

Button Neuer Newslettern erstellen fehlt 26 Jun 2020 14:36 #1825

  • sklemme
  • sklemme's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 0
Hallo,
habe es so eben probiert. Ich habe die Datei "pkg_bwpostman.2.3.1.zip" geladen. Diese konnte ich nicht installieren, die XML Datei wird nicht gefunden. Dann habe ich die einzelnen Pakete nacheinander manuel Installiert. Bei der Komponente bekomme ich aber ein Fehler: COM_BWPOSTMAN_INSTALLATION_ERROR_CREATING_USERGROUPS:

Woran kann liegt es? Ich habe eine Datensicherung der Tabellen vorher angefertigt.

Gruß Sebastian

Please Log in or Create an account to join the conversation.

Button Neuer Newslettern erstellen fehlt 26 Jun 2020 15:33 #1826

  • Karl
  • Karl's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 244
  • Karma: 9
  • Thank you received: 24
Hallo Sebastian,
ich habe mir den Programmcode angesehen und es könnte sein, dass daran der Fehler liegt.

Probiere bitte mal folgendes aus.
Gehe im Adminbereich auf Benutzer->Gruppen und bearbeite die Gruppe "Öffentlich".
Benenne diese Gruppe um in "Public" (P großgeschrieben) und probiere anschleißend nochmal die Installation.
Die Gruppe kannst du später wieder umbenennen.

Bitte teste das mal und schreibe uns das Ergebnis.

Gruß Karl

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum

Newsletter Subscription

Hint: Your entered data are only used to register to and sending of the newsletter. Your data will be processed and stored by me. For more information have a look at my privacy policy.

Your mailing list:

Standard
Infos about Joomla! extensions of Boldt Webservice, especially BwPostman. The newsletter will only be sent if there are any news.

Please help us prevent spam, and solve this little math question!

captcha

() Mandatory fields

Voluntary salary

If you like Boldt Webservice then I would be glad about your backing:
  • Recommend Boldt Webservice
  • If you want to support my work with a donation, please click on the following button - the donation will be handled via paypal.

With your voluntary salary you also support the development of free software and extensions for the CMS Joomla.

Enter your amount below and click on the following button: